+7 (4822) 666-101
+7 (4822) 667-118
+7 (499) 704-3940

Перейдите в каталог, выберите требуемый товар и добавьте его в корзину.

Mikrotik QoS для SIP телефонии

Раздача интернет- канала на несколько SIP- телефонов в «серой» сети за NAT.

Вообще-то речь пойдет не про QoS... Данный конфиг был найден где-то на просторах англоязычного Интернета и предлагает доволно спорный, но возможно, рабочий вариант приоретизации трафика по размеру пакета. В первоисточнике утверждается, что конфигарация слита с "боевого" роутера, и более того, используется провайдером при подключении абонентов...

# Включаем connection tracking:

/ip firewall connection tracking
set enabled=no generic-timeout=10m icmp-timeout=10s tcp-close-timeout=10s tcp-close-wait-timeout=10s tcp-established-timeout=1d tcp-fin-wait-timeout=10s tcp-last-ack-timeout=10s tcp-syn-received-timeout=5s tcp-syn-sent-timeout=5s tcp-syncookie=no tcp-time-wait-timeout=10s udp-stream-timeout=3m udp-timeout=10s

# В правилах файрвола блокируем весь трафик, относящийся к SMB:
/ip firewall filter
add action=drop chain=forward comment=»» disabled=no dst-port=445 protocol=tcp
add action=drop chain=forward comment=»» disabled=no dst-port=135-139 protocol=tcp

# Маркируем трафик для последующей передачи планировщику пакетов:
/ip firewall mangle
add action=mark-packet chain=prerouting comment=OSPF disabled=no new-packet-mark=ospf passthrough=no protocol=ospf
add action=mark-packet chain=prerouting comment=ICMP disabled=no new-packet-mark=icmp passthrough=no protocol=icmp
add action=mark-packet chain=prerouting comment= «Small Packets» disabled=no new-packet-mark=small packet-size=0-256 passthrough=no
add action=mark-packet chain=prerouting comment= «Large Packets» disabled=no new-packet-mark=large packet-size=257-1550 passthrough=no

# Здесь собственно, сам NAT для раздачи интернета:

/ip firewall nat
add action=src-nat chain=srcnat comment= «SRCNAT ethernet clients on IC->WS» disabled=no out-interface=ether1 src-address=__NATed_Addresses__/24 to-addresses=___INET_ADDRESS___

# Далее идут Service Ports (по терминологии Mikrotik) - то есть ALG:

/ip firewall service-port
set ftp disabled=no ports=21
set tftp disabled=no ports=69
set irc disabled=no ports=6667
set h323 disabled=no

# Следущее правило (SIP ALG, nat sip helper) далеко не везде стоит включать, так как современные SIP - железки и программы прекрасно умеют работать за NAT, и включение SIP ALG может их "запутать".
set sip disabled=no ports=5060,5061
set pptp disabled=no

/queue type
set default kind=pfifo name=default pfifo-limit=50
set ethernet-default kind=pfifo name=ethernet-default pfifo-limit=50
set wireless-default kind=sfq name=wireless-default sfq-allot=1514 sfq-perturb=5
set synchronous-default kind=red name=synchronous-default red-avg-packet=1000 red-burst=20 red-limit=60 red-max-threshold=50 red-min-threshold=10
set hotspot-default kind=sfq name=hotspot-default sfq-allot=1514 sfq-perturb=5
set default-small kind=pfifo name=default-small pfifo-limit=10

# Далее описание дерева очередей, с использованием местных идиоматических выражений. )   В общем, весь трафик идет по двум ветвям дерева очередей. В первой в первую очередь пропускаем пакеты OSPF (может кому надо?), затем пинги, а уж потом TCP. Во второй ветви разгребаем что осталось. То есть, видимо, UDP - пакеты. В первую очередь мелкие пакеты, которыми должен оказаться в основном голосовой трафик, а во вторую - пакеты покрупнее.


/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=GLOBAL packet-mark="" parent=global-in priority=8 queue=\
default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=PRIO-1 packet-mark="" parent=GLOBAL priority=1 queue=\
default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=OSPF packet-mark=ospf parent=PRIO-1 priority=1 queue=\
default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=ICMP packet-mark=icmp parent=PRIO-1 priority=2 queue=\
default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=TCPACK packet-mark=tcpack parent=PRIO-1 priority=3 \
queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=PRIO-2 packet-mark="" parent=GLOBAL priority=2 queue=\
default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=SMALL packet-mark=small parent=PRIO-2 priority=2 queue=\
default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=LARGE packet-mark=large parent=PRIO-2 priority=4 queue=\
default

# Привязываем очередь к конкретным интерфейсам:
/queue interface
set ether1 queue=ethernet-default
set ether2 queue=ethernet-default
set ether3 queue=ethernet-default
set LOOPBACK queue=default

SIP через NAT, Мини АТС, SIP, IP PBX, Mikrotik, Asterisk08.07.2013, 4970 просмотров.

Комментарии

высокобелковый гейнер
Если вы промышляете спортивными нагрузками и желаете привести себя в достойную форму, советуем начать использовать спортпит .

Ассортимент спортпита спортивное питание оптом купить . Вы можете заказать BCAA, л-карнитин и другие товары для спортивного питания по хорошей цене.

Если вы увлекаетесь пауэрлифтингом и хотите в сжатые сроки высушиться, предлагаем начать принимать жиросжигатели. Выбрать и купить их реально через kachosi.ru

На портале реально купить разные вещи по приемлемым ценам дешево. Ко всем брендам прикрепляются фотографии. Вы имеете шанс прочитать полное описание и советы на странице чёткого препарата, как на 5lb.

Спортивные добавки продаются как в форме смеси, так и в капсулах. Если вы давно стремились стать удачным в бодибилдинге, рекомендуем стартовать пользоваться услугами известного интернет-магазина Качоси в Москве, СПб или всему РУ сегменту!

SportoPap 26.02.2018 11:37:31 ответить #

Имя
E-mail
Телефон
Тема
Комментарий
Оценка
Показать другое число
Контрольное число*

Добавить комментарий

Имя
E-mail
Телефон
Тема
Комментарий
Оценка
Показать другое число
Контрольное число*

Новости

30 мая 2014 г.
Новый вирус взламывает пароли роутеров
01 октября 2013 г.
Новые безлимитные тарифы

Все новости

Метки

Интернет-магазин